setup.py
changeset 29 035058514c2d
parent 28 ec82f750a462
child 43 beb799c08f57
--- a/setup.py	Wed Dec 02 23:12:23 2009 +0100
+++ b/setup.py	Tue Dec 22 22:59:37 2009 +0100
@@ -20,17 +20,18 @@
 import os
 from setuptools import setup, find_packages
 
-version = '0.1'
+DOCS = os.path.join(os.path.dirname(__file__),
+                    'ztfy', 'utils', 'docs')
 
-README = os.path.join(os.path.dirname(__file__),
-          'ztfy',
-          'utils', 'docs', 'README.txt')
+README = os.path.join(DOCS, 'README.txt')
+HISTORY = os.path.join(DOCS, 'HISTORY.txt')
 
-long_description = open(README).read() + '\n\n'
+version = '1.0'
+long_description = open(README).read() + '\n\n' + open(HISTORY).read()
 
 tests_require = [
-        'zope.testing',
-    ]
+    'zope.testing',
+]
 
 setup(name='ztfy.utils',
       version=version,
@@ -67,4 +68,3 @@
       # -*- Entry points: -*-
       """,
       )
-