--- a/{{cookiecutter.project_slug}}/setup.py Sun Jan 14 12:29:44 2018 +0100
+++ b/{{cookiecutter.project_slug}}/setup.py Mon Jan 15 16:27:44 2018 +0100
@@ -13,7 +13,7 @@
{%- if cookiecutter.beaker_backend == 'redis' %}
'beakeredis',
{%- endif %}
-{%- if cookiecutter.use_oracle %}
+{%- if cookiecutter.use_oracle.lower() in ('true','on','yes','1') %}
'cx_Oracle',
{%- endif %}
'fanstatic',
@@ -21,23 +21,23 @@
'newt.db',
{%- endif %}
'nose',
-{%- if cookiecutter.use_postgresql %}
+{%- if cookiecutter.use_postgresql.lower() in ('true','on','yes','1') %}
'psycopg2',
{%- endif %}
'pyams_alchemy',
'pyams_catalog',
'pyams_content',
-{%- if cookiecutter.use_elasticsearch %}
+{%- if cookiecutter.use_elasticsearch.lower() in ('true','on','yes','1') %}
'pyams_content_es',
{%- endif %}
'pyams_default_theme',
'pyams_file',
'pyams_form',
-{%- if cookiecutter.need_pyams_gis %}
+{%- if cookiecutter.need_pyams_gis.lower() in ('true','on','yes','1') %}
'pyams_gis',
{%- endif %}
'pyams_i18n',
-{%- if cookiecutter.use_ldap %}
+{%- if cookiecutter.use_ldap.lower() in ('true','on','yes','1') %}
'pyams_ldap',
{%- endif %}
'pyams_notify',
@@ -62,7 +62,7 @@
'pyramid_beaker',
'pyramid_chameleon',
'pyramid_debugtoolbar',
-{%- if cookiecutter.use_elasticsearch %}
+{%- if cookiecutter.use_elasticsearch.lower() in ('true','on','yes','1') %}
'pyramid_es',
{%- endif %}
'pyramid_fanstatic',