--- /dev/null Thu Jan 01 00:00:00 1970 +0000
+++ b/{{cookiecutter.project_slug}}/setup.py Fri Jun 02 15:07:36 2017 +0200
@@ -0,0 +1,38 @@
+import os
+
+from setuptools import setup, find_packages
+
+here = os.path.abspath(os.path.dirname(__file__))
+with open(os.path.join(here, 'docs', 'README.txt')) as f:
+ README = f.read()
+with open(os.path.join(here, 'docs', 'CHANGES.txt')) as f:
+ CHANGES = f.read()
+
+requires = [
+ 'aiopyramid[gunicorn]'
+]
+
+setup(name='{{ cookiecutter.webapp_name }}',
+ version='0.0',
+ description='{{ cookiecutter.project_name }}',
+ long_description=README + '\n\n' + CHANGES,
+ classifiers=[
+ "Programming Language :: Python",
+ "Framework :: Pyramid",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Internet :: WWW/HTTP :: WSGI :: Application",
+ ],
+ author='',
+ author_email='',
+ url='',
+ keywords='Pyramid project using AsyncIO websockets',
+ packages=find_packages(),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=requires,
+ tests_require=requires,
+ test_suite='{{ cookiecutter.webapp_name }}',
+ entry_points="""
+ [paste.app_factory]
+ main = {{ cookiecutter.webapp_name }}:main
+ """)