setup.py
changeset 28 ec82f750a462
parent 0 712d20d2751e
child 29 035058514c2d
--- a/setup.py	Wed Dec 02 23:12:08 2009 +0100
+++ b/setup.py	Wed Dec 02 23:12:23 2009 +0100
@@ -1,5 +1,5 @@
 # -*- coding: utf-8 -*-
-# Copyright (c) 2008 'Thierry Florac'
+# Copyright (c) 2009 'Thierry Florac'
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -15,7 +15,7 @@
 # along with this program; see the file COPYING. If not, write to the
 # Free Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 """
-This module contains the tool of ztfy.utils
+This module contains ztfy.utils package
 """
 import os
 from setuptools import setup, find_packages
@@ -37,7 +37,10 @@
       description="ZTFY utility functions and classes for Zope3",
       long_description=long_description,
       classifiers=[
+          "License :: OSI Approved :: Zope Public License",
+          "Development Status :: 4 - Beta",
           "Programming Language :: Python",
+          "Framework :: Zope3",
           "Topic :: Software Development :: Libraries :: Python Modules",
       ],
       keywords='ZTFY utilities for Zope3',
@@ -48,6 +51,7 @@
       packages=find_packages(exclude=['ez_setup']),
       namespace_packages=['ztfy'],
       include_package_data=True,
+      package_data={'': ['*.zcml', '*.txt', '*.pt', '*.pot', '*.po', '*.mo', '*.png', '*.gif', '*.jpeg', '*.jpg', '*.css', '*.js']},
       zip_safe=False,
       # uncomment this to be able to run tests with setup.py
       #test_suite = "ztfy.utils.tests.test_utilsdocs.test_suite",
@@ -57,6 +61,7 @@
           'setuptools',
           # -*- Extra requirements: -*-
           'zope.app.zapi',
+          'zc.set'
       ],
       entry_points="""
       # -*- Entry points: -*-