--- /dev/null Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py Sat Jan 10 00:35:35 2009 +0100
@@ -0,0 +1,65 @@
+# -*- coding: utf-8 -*-
+# Copyright (c) 2008 'Thierry Florac'
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program; see the file COPYING. If not, write to the
+# Free Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+"""
+This module contains the tool of ztfy.utils
+"""
+import os
+from setuptools import setup, find_packages
+
+version = '0.1'
+
+README = os.path.join(os.path.dirname(__file__),
+ 'ztfy',
+ 'utils', 'docs', 'README.txt')
+
+long_description = open(README).read() + '\n\n'
+
+tests_require = [
+ 'zope.testing',
+ ]
+
+setup(name='ztfy.utils',
+ version=version,
+ description="ZTFY utility functions and classes for Zope3",
+ long_description=long_description,
+ classifiers=[
+ "Programming Language :: Python",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ],
+ keywords='ZTFY utilities for Zope3',
+ author='Thierry Florac',
+ author_email='tflorac@ulthar.net',
+ url='',
+ license='ZPL',
+ packages=find_packages(exclude=['ez_setup']),
+ namespace_packages=['ztfy'],
+ include_package_data=True,
+ zip_safe=False,
+ # uncomment this to be able to run tests with setup.py
+ #test_suite = "ztfy.utils.tests.test_utilsdocs.test_suite",
+ tests_require=tests_require,
+ extras_require=dict(test=tests_require),
+ install_requires=[
+ 'setuptools',
+ # -*- Extra requirements: -*-
+ 'zope.app.zapi',
+ ],
+ entry_points="""
+ # -*- Entry points: -*-
+ """,
+ )
+